ホーム » VirtualBox

VirtualBox」カテゴリーアーカイブ

2024年3月
 12
3456789
10111213141516
17181920212223
24252627282930
31  

カテゴリー

アーカイブ

ブログ統計情報

  • 74,832 アクセス

VERR_UNRESOLVED_ERROR

Win11 上の仮想マシン Mint を起動しようとすると,
VM Name: Mint
Unresolved (unknown) host platform error. (VERR_UNRESOLVED_ERROR).
Result Code:
E_FAIL (0X80004005)
Component:
ConsoleWrap
Interface:
IConsole {6ac83d89-6ee7-4e33-8ae6-b257b2e81be8}
VirtualBox VERR_UNRESOLVED_ERROR
検索しても該当しそうなものがわからない.
多く見つかるのは,Hyper-V などの無効化.


PC を再起動させよう思い,他の仮想マシンを「保存」して,試しに Mint を起動するとうまく起動した.
それで,「保存」した他の仮想マシンを起動しようとすると同様のエラーに.
こうなると,システムリソースの問題と思い,プロセッサ数を減らすが効果はない.
次にメモリ量を減らしてうまく起動した.
先日作成した WS 2019 のメモリ量を 6G から 4G にして運用することにした.
VirtualBox  Mint


Mint 環境でコンパイルできる様に,共通のコードを参照するための mount .
/mnt/_.src を作成して,Fedora 環境にあった .sh をコピー.が,エラーとなる.
以前やった時を見直すと,IP で指定しないとうまくいかないことがあった
.sh を書き換えてうまくいった.
Mint   mount  IP

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

WS 2019 ,IIS インストール

AS5202T 上の WS2022 が,最近不安定な気がする.
元々,WSS の代わりと,テスト環境の IIS を 24 時間動かせると思い設定したもの.


Windows Update などのためにデスクトップを表示すると,フリーズしてしまう.
AS5202T 上の WS2022
ログインしない状態では特に問題ない.


今回 IIS(Classic ASP)のテストが必要になり,PC の仮想環境に WS 2019 をインストールすることにした.
使用した iso が 2021/04 にダウンロードしたものだったので,ブラウザの更新などがうまくできない.
Window Update である程度の所まで上げる必要があるのか?
WS 2019  Windows Update


Classic ASP のインストール.手順は WS 2022 と同様.
WS 2019 に Classic ASP のインストール


次のメッセージが表示される場合,ASP の設定が必要.
An error occurred on the server when processing the URL. Please contact the system administrator.
If you are the system administrator please click here to find out more about this error.
Win10 IIS 「ASP」-「デバッグ プロパティ」-「ブラウザへのエラー送信」


今回は,本番の環境で次のエラー.ログを表示するページのデータ量が 4 MB を超えたと思われる.


Response オブジェクト エラー ‘ASP 0251 : 80004005’
応答バッファー処理の制限の超過
/_CMN_/DrawLogAccess.asp, 行 0
ASP ページの拡張が原因で、応答バッファーが構成された制限を超過しました。


対応方法は次の所にある.
IIS で Response.BinaryWrite を使用しているときに HTTP 500 または応答バッファーの制限を超えた場合のエラー
管理者として実行」したコマンドプロンプトから操作する必要があった.
また「ASP」-「動作」-「制限プロパティ」-「応答バッファー処理の制限」でも変更可能.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

VirtualBox PXE-E06

Win11 上の仮想マシン Win10 の Windows Update での再起動で,
PXE-E06: Option ROM requires DDIM support.
PXE-E06: Option ROM requires DDIM support.
検索してみた が,あまりいい情報に引っ掛からない.


Windows Update での再起動だったので心配だったが,仮想マシンを一度 OFF して,再起動.
特に何もなかったかの様に起動した.
何だったのだろう.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

VirtualBox 7.0 に更新

Win10 と Win11 の ViurtalBox を 6.1.40 から 7.0.4 に更新した.
4K 環境になってから,いろいろと表示でうまくない部分があった.


Win10 環境は,Win11 の仮想マシンを除いては問題なさそう.
Win10  VirtualBox 7.0.4
一度 Win11 仮想マシンを「除去」して,作成し直してみたが,うまく動作しない.
起動中の「お待ちください」の表示で止まってしまう.
仮想マシンの「設定」-「ディスプレイ」の「3Dアクセラレーションを有効化」にチェックして止まらなくなった.
「設定」-「ディスプレイ」-「スクリーン」-「3Dアクセラレーションを有効化」
どこかに設定があるものと思うが,OpenGL での表示がうまくされない.
VirtualBox 7  OpenGL 表示ができない?


Win11 環境は,LAN 関係のエラーでうまく起動しない.
6.1.40 に戻したがうまく起動しなくなってしまった.
Win11 VirtualBox 7  VERR_SUPDRV_COMPONENT_NOT_FOUND
「ネットワークアダプターを有効化」のチェックを外せば起動するが,これだとあまり使い物にならない.
ASUSTOR NAS でも同様のエラー になったことがあるので,設定ではないのか?


もう一度 7.0.4 にしてみたが,変わらず.
VM Name: Win10-VS6
Failed to open/create the internal network ‘HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter’ (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Result Code:
E_FAIL (0X80004005)
Component:
ConsoleWrap
Interface:
IConsole {6ac83d89-6ee7-4e33-8ae6-b257b2e81be8}
Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter' (VERR_SUPDRV_COMPONENT_NOT_FOUND).


アンインストールやデバイスの削除を行って,再度インストールしたら少し動作する様になった.
デバイスマネージャーで VirtualBox Host-Only Ethernet Adapter がうまくなかったので,そこが原因だったか?
まだうまく動作しない仮想マシンもあるが,あとは個別の設定なので何とかなるかな?


2023/06/05
Win11 環境で 7.0.8 にあげて,LAN 関係で同じ様な現象.
PC を再起動して,うまく動作する様になった.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

Win11 VHD

新しく手に入った Win11 を VHD としてバックアップ.
Disk2vhd.exe で VHD に.
zip をダウンロードして解凍すると 3 つの exe になっている.x86,x64,arm で分かれた?
Disk2vhd v2.02 zip
使用する exe は disk2vhd64.exe .
Disk2vhd WIn11 C SYSTEM Recovery
ViritualBox 6.1.38 を Win11 環境にインストール.
先ず,以前とっておいた Win7 vhd 6.5 GB を起動させてみると,
VirtualBox STOP: 0x0000007B
これは,以前書いていて,今回追記した.
https://dev.mish.work/wordpress/2019/05/01/virtualbox-win7-vhd-0x0000007b/


バックアップした VHD で起動.
特に設定を変更していなかったので,起動にはかなりの時間(10 分程度)がかかった.
仮想マシンの Win11 を起動して VirtualBox Guest Additions  をインストール


今度は,仮想マシンに Win11 の iso を利用して OS のインストールから.
起動するとうまく動作しない.
Win11 iso を利用したインストールでうまくない
もう一度.次の表示が出ている時に何かのキーを押すと iso の読込みが始まる.
Press any key to boot from CD or DVD…
Win11 のインストールの開始
が,「この PC では Windows 11 を実行できません」.
この PC では Windows 11 を実行できません
戻って「コンピューターを修復する」を選択.
「コンピューターを修復する」
「トラブルシューティング」-「コマンドプロンプト」.
\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig を作成して次のものを追加しなければならないらしい.
BypassTPMCheck と BypassSecureBootCheck で,値は DWORD 1 .
\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig BypassTPMCheck BypassSecureBootCheck
レジストリエディタを終了して,コマンドプロンプトで setup.exe .
あとはいつも通り.


2022/10/06
「この PC では Windows 11 を実行できません」となった時の一般的に書かれている方法.
「Shift」+「F10」でコマンドプロンプトが表示される.
RegEdit を入力.
BypassTPMCheck と BypassSecureBootCheck の追加.
Win11 Shift+F10 Bypass...Check
レジストリエディタや「この PC では Windows 11 を実行できません」を閉じる.
「本当に終了しますか?」を「はい」で閉じる.
「今すぐインストール」の画面に戻り「今すぐインストール」で続ける.


これらのことをやっていて,ひょっとして今までメインで使用していた Win10 環境でも動くのでは?
CPU が i5-6400 で少し古いため動作対象外となっている.
Win10 の VirtualBox 上で Win11

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

ADM 4.1.0.RLQ1 VirtulBox …

時々ある ことなので驚きはしないが…
ADM 4.1.0.RLQ1 にアップデートして VirtualBox の仮想マシンがうまく起動しなくなった.


Failed to open/create the internal network ‘HostInterfaceNetworking-eth0’ (VERR_SUPDRV_COMPONENT_NOT_FOUND). Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND). One of the kernel modules was not successfully loaded. Make sure that VirtualBox is correctly installed, and if you are using EFI Secure Boot that the modules are signed if necessary in the right way for your host system. Then try to recompile and reload the kernel modules by executing ‘/sbin/vboxconfig’ as root (VERR_SUPDRV_COMPONENT_NOT_FOUND)
ADM 4.1.0.RLQ1 で VirtualBox の仮想マシンがうまく起動しなくなった?


設定があるのかもしれないが,検索してもちょっとわからない.
最近の ADM アップデートはあまり安定していない気がする.
それとも,数日仮想マシンを起動していなかったので,どこか弄ってしまったか?


2022/10/05
対応版が出たみたい.
ASUSTOR NAS VirtualBox 6.1.32.r3
うまく起動する様になった.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 1 人中 1 人がこの 投稿 は役に立ったと言っています。

ADM 4.1.0.RJ52 の更新で …

ASUSTOR NAS の ADM 4.0 から 4.1 への更新で?,Web サーバなどが動作しなくなった.
「Web Center」で「Web サーバー」を設定.
ADM 4.1  「Webサーバー」の設定
これで //as.mish.work/ でアクセスできるようにはなった.


が,WordPressJoomla! がうまく動作していない.
「Apache HTTP Server」に切替えれば良いものと思うが,エラーになってしまう.
ADM 4.1  Webサーバー  「Apache HTTP Server」でエラー


WordPress は,それぞれの記事の表示で「404 Not Found」となっていまう.
Joomla! は「グローバル設定」-「SEO設定」-「フレンドリURL」を「いいえ」で動作する様にはなる.
どこかの設定が足りないものと思うが,ちょっとわからないのでこのままとする.


「保存」した VirtualBox の環境が起動できない.
ADM 4.1  保存した VirtualBox 環境が起動しなくなった
「保存状態を破棄」して起動できた.


夜になって,ADM 4.1.0.RJ72 がリリースされている.
更新後,「Apache HTTP Server」を指定できることを確認.
WordPress と Joomla! はうまく機能する様になった.
ファームの不具合だった?


更新して,今度は VirtualBox に入れなくなってしまった.
ADM 4.1  VirtualBox にログインできない
Linux Center は問題なさそう.


2022/07/13
ADM 4.1.0.RJD1 があった.
更新して,起動できる様になったことを確認.
ADM 4.1  VirtualBox 起動できる様になった

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

AS5202T VirtualBox に WS2022

ASUSTOR NAS AS5202T の VirtualBox 環境に Windows Server 2022 のインストール.
最初,リモート接続するための設定箇所がわからなかった.
Net Address の所に,アドレス(127.0.0.1 だったと思う)が入っていて,それをクリアする必要があった.
VirtualBox Remote Display Net Address をクリア
あとは,通常の手順.
ASUSTOR NAS に WS2022 インストール


「Ctrl」+「Alt」+「Delete」にあたるものがわからなかったが,これは,「Ctrl」+「Alt」+「End」.
「Ctrl」+「Alt」+End」


マウスの位置がずれていたが,VirtualBox Guest Additions を入れて対応.


VS 6 と SP6 を入れて,今の所デバッグなどもできている.
https://dev.mish.work/wordpress/2021/06/10/win-10-vs6-install/


2021/11/10
リモートデスクトップ内の画面コピーは,「Ctrl」+「Alt」+「+」.
アクティブウィンドウのコピー     「Ctrl」+「Alt」+「-」.


2021/11/29
LAN 上の他の PC からの参照は問題なさそうだが,WS2022 から他の PC への参照が非常に遅い.
以前同じ様な環境に Win10 を入れていたが,この時も他からの参照のみだったので気づかなかった.
PC 上の仮想マシン は,速くはないが使えるレベル.NAS なので,これが限度か?


この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

VirtualBox BLKCACHE_IOERR

今まで特に問題なく使えていた VHD が今日の午前中から調子が悪い.
VirtualBox BLKCACHE_IOERR

仮想マシンの実行中にエラーが発生しました!エラーの詳細を以下に示します。説明されたエラーを修正し、仮想マシンの再実行することができます。
The I/O cache encountered an error while updating data in medium "ahci-0-0" (rc=VERR_IO_CRC). Make sure there is enough free space on the disk and that the disk is working properly. Operation can be resumed afterwards.
エラーID: BLKCACHE_IOERR
重要度: 致命的でないエラー

検索すると「ホストの I/O キャッシュを使う」とあったが…
ホストの I/O キャッシュを使う
チェックを付けて起動させると,
スタートアップ修復
どうも違うみたいで,元に戻した.


どこかが壊れたのか?安定しない.
ブルースクリーンになってしまう


2021/02/28
どうも物理ディスクに障害が発生しているみたい.
突然ホストがブルースクリーンに.
Z170S0 がブルースクリーンに
起動後,ディスクの状態が「注意」となっていて「代替処理保留中のセクタ数」の所が黄色に.
代替処理保留中のセクタ数
イベントビューアを見ると disk のエラーがいっぱい.
イベントビューア 「disk 」のエラー
さかのぼって調べるとさらに 1 週間前位にもあり.
イベントビューア 「disk 」のエラー 2021/02/19
D ドライブのものをバックアップしていて,対象の VHD をコピーしている時読み取りエラーとなった.
VHD 「送り側のファイルまたはディスクから読み取れません」
最近,ホストの Windows Update 後などの再起動が遅いと感じていたが,この辺りが原因だったか?
PC の内蔵ディスクが壊れた?

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

NAS VirtualBox に Win10 … 続き

今日 ASUSTOR NAS AS5202T の ADM を起動すると VirtualBox の更新版があった.
新しいものは 6.1.12.r01 .以前のものは 5.2.22 だったと思う.


以前 PC で作成した vdi を NAS にコピーして利用している環境 DevX .
5.2 の時よりも起動は安定したか?止まってしまうこともあり.


前回,インストールしようとしたが操作ができずそのままとなっていた.
VirtualBox の更新でどこかの設定が変更されたのかはわからないが,以前選択できなかった「リモートデスクトップ」の設定に入れるようになった.
ASUSTOR NAS VirtualBox 「リモートデスクトップ」設定
Win10 PC の「リモートデスクトップ接続」で接続してインストール.
ASUSTOR NAS リモートデスクトップ接続
いつもの様に進めていくと「Microsoftアカウント」の入力に.
Win10 LTSC 2019 「ローカルアカウント」の入力に
「代わりにドメインに参加する」を選択すると「ローカルアカウント」での入力ができた.


https://jml.mish.work/various/nas/asustor.html

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

NAS VirtualBox に Win10 … できず

ASUSTOR NAS の VirtualBox で動作させている Win10 が不安定なので,VirtualBox 上にインストールから…


ASUSTOR NAS の VirtualBox で作成した vdi をコピーしてそれを指定すると,
VirtualBox error: rc=0x80bb0001 Cannot register the hard disk ‘/volume1/Public/VHD/DevA/DevA.vdi’ {f7577f3a-2c71-49bb-b349-5b6aa27133bd} because a hard disk ‘/root/VirtualBox VMs/DevA/DevA.vdi’ with UUID {f7577f3a-2c71-49bb-b349-5b6aa27133bd} already exists (0x80070057)
vdi コピーでエラー
コマンドプロンプトで,
Microsoft Windows [Version 10.0.18362.1016]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\Users\Iwao>cd %TMP%

C:\Users\Iwao\AppData\Local\Temp>"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" internalcommands sethduuid B:\VHD\DevA\DevA.vdi
UUID changed to: 7bf3a9e5-06f0-4718-b8ed-c48322cc99f9

C:\Users\Iwao\AppData\Local\Temp>


コピーした vdi を選択して起動すると,
UUID {bee82a51-4b3e-4856-9d86-f035dee8bd25} of the medium ‘/volume1/Public/VHD/DevA/DevA.vdi’ does not match the value {7bf3a9e5-06f0-4718-b8ed-c48322cc99f9} stored in the media registry (‘/root/.config/VirtualBox/VirtualBox.xml’)
コピーした vdi を選択して起動するとエラー
検索 してわかりやすかったのが次の所.
https://katurakuno.xsrv.jp/Linux/LinuxMint/virtualbox/error.html
C:\Users\Iwao\AppData\Local\Temp>"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" internalcommands sethduuid B:\VHD\DevA\DevA.vdi 7bf3a9e5-06f0-4718-b8ed-c48322cc99f9
UUID changed to: 7bf3a9e5-06f0-4718-b8ed-c48322cc99f9

C:\Users\Iwao\AppData\Local\Temp>


VirtualBox 内でセットアップは起動するが,リモートデスクトップサーバとして動作させる方法がわからない.
AS5202T VirtualBox Win10 インストール
今までは既存の vdi を使用していたが,インストールからとなると NAS 本体に接続するしかないのか?
以前,一時的に仮想マシンが起動する前に RDP 接続できていた時があったが,どこかの設定なのか?
QNAP NAS の Virtualization Station は,ブラウザから操作が可能


2020/09/20
VirtualBox の更新があり?リモートデスクトップ接続 できるようになった.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

TS-253D セットアップ – 4

Virtualization Station 3 のエクスポート.
先日作成した Win10 を VirtualBox などで開くためにエクスポート.
仮想マシンの下にある「エクスポート」ボタンを押して,*.ovf で「スタート」.
Virtualization Station 3 で ovf のエクスポート
18 GB の img で 40 分位かかった.出力された vmdk は 9 GB .
AS5202T の VirtualBox で「ファイル」-「仮想アプライアンスのインポート」.
ASUSTOR NAS VirtualBox 仮想アプライアンスのインポート
変換に 5 分位.
そのまま実行すると 0xc0000225 .
チップセットを「ICH9」,「I/O APIC を有効化」にチェック.
AS5202T VirtualBox の仮想マシンの設定
安定して動作はするが,どこかで間違えたみたいでネットワークがうまく機能しない.
AS5202T phpVirtualBox
PC の VirtualBox で読み込んでみたが,やはりネットワークがうまく動作していない.
PC の VirtualBox でもネットワークがうまくない


今度は VirtualBox のエクスポート.
PC の VirtualBox で「仮想アプライアンスのエクスポート」,AS5202T 上の DevX をエクスポート.50 分位.
VirtualBox 仮想アプライアンスのエクスポート
QNAP NAS Virtualization Station 3 で「VM のインポート」.20 分位.
TS-253D Virtualization Station 3 「VM のインポート」
最初うまく起動しなかった(実際は表示がうまくされていなかっただけ?).
「設定」-「ビデオ」-「タイプ」を「Cirrus」になっていたものを「VGA」に.
Virtualization Station 3 「設定」-「ビデオ」-「タイプ」を「VGA」に
これでうまくいった.VNC 接続も問題なし.
Virtualization Station 3  VNC 接続

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

TS-253D セットアップ – 2

今回の NAS で一番気になっている Virtualization Station 3
ASUSTOR NAS にも同様の目的の VirtualBox がある が,再起動時の安定度があまり良くない
2020/09/21 ASUSTOR NAS VirtualBox は 6.1.12 になり安定している.


「Virtualization Station 3」-「VM の作成」.
Virtualization Station 3  VM の作成
「OK」で「自動インストール」のメッセージが表示される.
Virtualization Station 3 「自動インストール」の確認
ここは「キャンセル」(「自動インストール」ではうまくいかなかった).
Virtualization Station 3 Win10 インストール開始
Virtualization Station 3 Win10 インストール終了
あまり速くない?
Virtualization Station 3 QNAP Guest Tools のインストール
ブラウザで操作していたため動きが悪かったのかもしれない.VNC 接続だとそれほど気にならない.
「Guest Tools」のインストールでは「Ultra VNC」もインストール可能になっている.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

AS5202T VirtualBox – 2

AS5202T の CPU 温度を見るといつもより高い.
「プロセス」情報を見ると VirtualBox が消費している.
AS5202T の「プロセス」状態
VNC で接続すると TiWorker.exe が CPU を食っている.
DevX  TiWorker.exe
丁度 Windows Update のタイミングみたい.
VNC 接続の仮想マシンは遅くて操作できないが,接続しているクライアントからソースなどは見える.
TiWorker が CPU を食っている
前回 の様なネットワークが途切れる状態にはまだなっていない.


「リモートデスクトップ」であれば仮想マシンも操作できた.
落ち着くまでそのままにしておくしかなさそう.


その後「再起動」待ちになっていたので仮想マシンを再起動.
また止まったような表示.
Windows Update の再起動で,止まったような状態?
CPU は食っているのでこのまま様子見.


2020/06/11
そのまま変わらないので,仮想マシンの「電源オフ」.
PC の VirtualBox で再起動.
2020/06 Windows Update
Windows Update での再起動がうまく動作しないのか?


AS5202T VirtualBox の仮想マシンとして起動した時,いつもより時間がかかることがある.
また,ネットワークがうまく接続されていないこともあり.
安定するまで何度か再起動の必要があるのかもしれない.
起動時止まった様に見えても 30 分程度はそのままにして様子を見た方が良さそう.
仮想マシンの CPU や HDD などのリソースへのアクセス状況が見えると良いのに…

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

VirtualBox 6.1.8 に

前から VirtualBox の 6.1 があるのは知っていたが…
6.0.20 から上げてみた.


PC へのインストール手順はいつもと同じだが,前バージョンのアンインストールに時間がかかっていた.
6.1.8 に更新後「保存」状態だった仮想マシンを起動すると,


仮想マシン”Test10″のセッションを開けませんでした。
pci#0: Device vga/0 failed to respond to region #0 size/type changing from 0x0000000002000000/0x8 to 0x0000000002000000/0x0: VERR_SSM_LOAD_CONFIG_MISMATCH [ver=4 pass=final] (VERR_SSM_LOAD_CONFIG_MISMATCH).
終了コード : E_FAIL (0x80004005)
コンポーネント: ConsoleWrap
インターフェース: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
仮想マシン"Win10"のセッションを開けませんでした。


Win7 も同様.Linux の仮想マシンは問題なかった.
Windows の仮想マシンは「破棄」して「起動」させれば OK .


Win10 IP 環境の 2004 への更新は,相変わらず.
Win10 IP 環境の 2004 への更新 86%
86% で再起動した時に失敗してしまう.
Win10 IP 2004 インストールの修復を試みています...

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

Win10 2004 インストール

Win10 Ver.2004 があったので VirtualBox 仮想マシンにインストールしてみた.
使用したのは ja_windows_10_business_editions_version_2004_x64_dvd_ee7b2698.iso .


最初,何も考えずにインストールしたら「Microsoft アカウント」と結びついたものになってしまった.
インストール途中で「ローカル アカウント」にする方法は気がつかなかった.


そのため,もう一度やり直し.ネットワークを切断した状態でインストール
今度はうまくいった.
Win10 2004 「ローカルアカウント」でインストール


2020/08/31
ローカルアカウントでインストールするための選択画面
ローカルアカウントでインストールするための選択画面
左下の「オフライン アカウント」を選択する.


2020/09/20
次の画面の場合は「代わりにドメインに参加する」を選択.
Win10 LTSC 2019 「ローカルアカウント」の入力に

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

AS5202T VirtualBox

以前よりは良くなってきたと思うが,昨夜からまた調子が…


昨夜 ASUSTOR NAS の OS ADM のアップデートがあったので更新した.
ASUSTOR NAS ADM 3.5.0.R5D3
ADM 更新後 VirtualBox も問題なく起動してうまく動作していると思ったが…
仮想マシン DevX がネットワークから見えない.
リモートデスクトップでは開けるが,VNC ではつながらない.
DevX を再起動すると,途中で止まってしまうことも…


今回試したこと.
AppCentral の VirtualBox 5.2.22.r08 を一度 OFF にして ON に.
仮想マシンの設定は変更していない.


これでうまく起動したが,何度か再起動させると止まってしまった.
AS5202T VirtualBox
もう一度 AppCentral で OFF にして ON に.
これで起動したのでそのままに.


2020/09/21
6.1.12 に更新.安定している.

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

AS5202T 再セットアップ – 7

VirtualBox が安定しない.
暫く問題なく使えていたのに,また起動しなくなってしまった.
うまく動作しなくなったきっかけは,間違って VirtualBox を OFF にしてしまった.
AS5202T App Central
本当は PHP 7 を OFF にするのを間違えた.


どうすれば確実なのかはわからないが,とりあえず起動したのでメモ.


同じ vdi を Win10 の VirtualBox からも起動可能にしているので,そちらで起動することを確認.
どのタイミングか忘れたが,VirtualBox Guest Additions が 6.0 になっていたのでそれをアンインストール.
いろいろと設定を変更して試したがうまく起動したのが次の様な設定.
チップセット: ICH9 .PAE/NX を有効化.VT-x/AMD-V を有効化.ネステッドページングを有効化.Enable Large Page にチェック.
AS5202T VirtualBox DevX の設定


これで起動を確認.
関係の有無はわからないが VirtualBox Guest Addtions 5.2.22 をインストールしたらまた起動しなくなった.
そのため再度 Win10 の VirtualBox で起動して VirtualBox Guest Addtions をアンインストール.
アンインストール後起動することを確認.


設定により CPU の使用率が減った?
AS5205T  CPU 使用率


2020/05/04
その後少しは良くなった気もするが,完全ではない.
意図せず止まってしまっていて,その後一時起動しなくなってしまった.
それで今日調べてみて気になった所.
ASUSTOR NAS のチュートリアル NAS 249
Virtual Machine Configuration with VirtualBox
次の様に書かれているので,両方の「..アクセラレーション…」にチェックを付けて様子見.
Please first select the [Enable 3D Acceleration] and [Enable 2D Video Acceleration] options and then set the Video Memory to [128 MB].
それから「リモートデスクトップ接続」で,起動中でも接続できることを見つけた.
AS5202T VirtualBox リモートデスクトップ接続


2020/05/05
いろいろ弄っていたらまた不安定に.
一時は VNC など DevX 192.168.1.88 に接続できなくなった.
ICH9 ,I/O APIC を有効化.
PAE/NX を有効化.
Legacy ,VT-x/AMD-V を有効化,ネステッドページングを有効化.
AS5202T VirtualBox


2020/09/21
6.1.12 に更新安定している

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

AS5202T 再セットアップ

やっとこの NAS 用の HDD が届いたのでもう一度最初からセットアップ.


今ある WD Red 1TB を外すために AS5202T をシャットダウン.
前回と同様 で「初期化されていません」を押して,画面の指示に従ってインストール.
今回は最初のインストールでは何も入れなかったので,Web サーバなども起動していない.
Web サーバの有効化
他に SSH なども有効になる様に設定.


SSH で接続しようとすると,

Microsoft Windows [Version 10.0.18362.720]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\Users\Iwao>cd %TMP%

C:\Users\Iwao\AppData\Local\Temp>ssh -l Iwao -p 22 192.168.1.75
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:7Hi9lqmKbdEhkCwGwU4j0fjj/PQCNQBfnNCIHKMACZA.
Please contact your system administrator.
Add correct host key in C:\\Users\\Iwao/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in C:\\Users\\Iwao/.ssh/known_hosts:16
ECDSA host key for 192.168.1.75 has changed and you have requested strict checking.
Host key verification failed.

C:\Users\Iwao\AppData\Local\Temp>

c:\Users\Iwao\.ssh\known_hosts を編集(192.168.1.75 の行を削除)して対応.


ここまでやっていろいろ見ていると,間違いを発見.RAID 0 になっている.
AS5202T RAID0
「設定」-「工場出荷時設定」-「システム初期化」でもう一度やり直し.
システム初期化
「ワンクリックセットアップ」の画面で「バランスが取れている」を選択する必要があった.
ワンクリックセットアップ バランスが取れている
「最大容量」だと RAID 0 .RAID 1 は「バランスが取れている」にする.


退避しておいた VHD などをコピー.
VirtualBox と entware をインストール.
VirtualBox DevX
SSH 接続で gcc のインストール.
opkg install gcc
これで gcc も使える様になった.


2020/04/05
その後いろいろ試していて,また VirtualBox が止まる?現象があった.
同じファイルを PC から起動するのはうまくできる.
先日バックアップした DevX.vdi をコピーし直して起動させたらうまくいった.
VNC 接続で時刻を表示させて見ていると,少し止まったようになることがある.
VirtualBox VNC 時刻の更新が止まる?


昨日 RAID 1 で再セットアップした後,ディスクが動いていたのでそのグラフ.
AS5202T RAID 1 ディスク


https://jml.mish.work/various/nas/asustor.html

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。

AS5202T セットアップ

先日届いていた AS5202T .それ用の HDD を注文したら納期がかかるみたい.
それで手元にあった WD Red 1TB を取り付けてセットアップしてみた.
NAS に取り付ける時,斜めになってしまうことがあるので注意が必要.


最初に ASUSTOR コントロールセンター をダウンロードして PC にインストール.
ASUSTOR Control Center
「初期化されていません」を押して,画面の指示に従って ADM をインストール.
AS5202T 初期化 1
AS5202T 初期化 2
AS5202T 初期化 3
AS5202T Portal
Web もセットアップされていた.
AS5202T web


NAS が動作することは確認できたので,メモリを 8GB に取り換え.
電源を入れると,一番上の青いランプが点灯,システムステータスのランプが点滅のままでうまく起動しない.
通常であればネットワークやハードディスクのランプが点滅や点灯するはず.
もう一度メモリを外して元の 2GB の状態にするとうまく起動する.
追加で 1 枚さして 6GB でもうまく起動.
2GB も交換して 4GB x 2 の状態で試すとうまく起動した.
メモリの挿し方が甘かった?


今回この機種を追加した目的の一つが VirtualBox .
App Central から VirtualBox と VirtualBox Extension Pack をインストール.
追加された VirtualBox アイコンをクリックすると新しくブラウザのウィンドウが開く.
AS5202T VirtualBox ログイン
この時のログインの ID がわからなかったが admin と admin で入れる.
https://www.asustor.com/en/online/College_topic?topic=249
https://forest.watch.impress.co.jp/docs/shseri/siranas/1023605.html
https://mdw-note.net/tips/setting-virtualbox-as3102t/
以前 PC で作成した Win10_LTSC.vdi を NAS の Public/VHD/Win10_LTSC にコピー.
それを使用する様に VirtualBox の仮想マシンを追加.
追加した仮想マシンを起動すると右上にプレビューが表示されている.
AS5202T VirtualBox
この仮想マシンは VNC サーバの設定がしてあるので,VNC ビューアから接続.
AS5202T VirtualBox VNC 接続


もう一つ確認したのが gcc .
App Central で entware を追加.
ASUSTOR NAS App Central 「entware」

C:\Users\Iwao\AppData\Local\Temp>ssh -l Iwao -p 22 192.168.1.75
Password:
Iwao@AS5202T:/volume1/home/Iwao $ gcc
-sh: gcc: not found
Iwao@AS5202T:/volume1/home/Iwao $ opkg
opkg must have one sub-command argument
usage: opkg [options...] sub-command [arguments...]
where sub-command is one of:

Package Manipulation:
        update                  Update list of available packages
        upgrade <pkgs>          Upgrade packages
        install <pkgs>          Install package(s)
        configure <pkgs>        Configure unpacked package(s)
        remove <pkgs|regexp>    Remove package(s)
        flag <flag> <pkgs>      Flag package(s)
         <flag>=hold|noprune|user|ok|installed|unpacked (one per invocation)

Informational Commands:
        ...

Iwao@AS5202T:/volume1/home/Iwao $ opkg install gcc
Installing gcc (7.4.0-5) to root...
Downloading http://bin.entware.net/x64-k3.2/gcc_7.4.0-5_x64-3.2.ipk
Installing zlib (1.2.11-3) to root...
Downloading http://bin.entware.net/x64-k3.2/zlib_1.2.11-3_x64-3.2.ipk
Installing libiconv-full (1.11.1-4) to root...
Downloading http://bin.entware.net/x64-k3.2/libiconv-full_1.11.1-4_x64-3.2.ipk
Installing libintl-full (0.19.8.1-2) to root...
Downloading http://bin.entware.net/x64-k3.2/libintl-full_0.19.8.1-2_x64-3.2.ipk
Installing libbfd (2.27-1) to root...
Downloading http://bin.entware.net/x64-k3.2/libbfd_2.27-1_x64-3.2.ipk
Installing libopcodes (2.27-1) to root...
Downloading http://bin.entware.net/x64-k3.2/libopcodes_2.27-1_x64-3.2.ipk
Installing objdump (2.27-1) to root...
Downloading http://bin.entware.net/x64-k3.2/objdump_2.27-1_x64-3.2.ipk
Installing ar (2.27-1) to root...
Downloading http://bin.entware.net/x64-k3.2/ar_2.27-1_x64-3.2.ipk
Installing binutils (2.27-1) to root...
Downloading http://bin.entware.net/x64-k3.2/binutils_2.27-1_x64-3.2.ipk
Configuring zlib.
Configuring libiconv-full.
Configuring libintl-full.
Configuring libbfd.
Configuring libopcodes.
Configuring objdump.
Configuring ar.
Configuring binutils.
Configuring gcc.
There are no *-dev packages in Entware(with few exceptions)!
Please install headers as described in the wiki:
https://github.com/Entware/Entware/wiki
Iwao@AS5202T:/volume1/home/Iwao $
Iwao@AS5202T:/volume1/home/Iwao $ gcc
/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crt1.o: In function `_start':
(.text+0x20): undefined reference to `main'
collect2: error: ld returned 1 exit status
Iwao@AS5202T:/volume1/home/Iwao $ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/lto-wrapper
Target: x86_64-openwrt-linux-gnu
Configured with: /media/ware3/Entware.2020.01/build_dir/target-x86_64_glibc-2.27/gcc-7.4.0/configure --target=x86_64-openwrt-linux --host=x86_64-openwrt-linux --build=x86_64-pc-linux-gnu --program-prefix= --program-suffix= --prefix=/opt --exec-prefix=/opt --bindir=/opt/bin --sbindir=/opt/sbin --libexecdir=/opt/lib --sysconfdir=/opt/etc --datadir=/opt/share --localstatedir=/opt/var --mandir=/opt/man --infodir=/opt/info --disable-nls 'CXXFLAGS_FOR_TARGET=-g -O2 -D_GLIBCXX_INCLUDE_NEXT_C_HEADERS' --build=x86_64-pc-linux-gnu --host=x86_64-openwrt-linux-gnu --target=x86_64-openwrt-linux-gnu --enable-languages=c,c++ --with-bugurl=https://dev.openwrt.org/ --with-pkgversion='OpenWrt GCC 7.4.0' --enable-shared --enable-__cxa_atexit --with-default-libstdcxx-abi=gcc4-compatible --enable-target-optspace --with-gnu-ld --with-specs='-Wl,-rpath=/opt/lib -Wl,--dynamic-linker=/opt/lib/ld-linux-x86-64.so.2' --with-boot-ldflags='static-libstdc++ -static-libgcc -Wl,-rpath=/opt/lib -Wl,--dynamic-linker=/opt/lib/ld-linux-x86-64.so.2' --disable-nls --disable-libsanitizer --disable-libvtv --disable-libcilkrts --disable-libmudflap --disable-libmpx --disable-multilib --disable-libgomp --disable-libquadmath --disable-libssp --disable-decimal-float --disable-libstdcxx-pch --with-host-libstdcxx=-lstdc++ --prefix=/opt --libexecdir=/opt/lib --with-local-prefix=/opt --with-stage1-ldflags='-lstdc++ -Wl,-rpath=/opt/lib -Wl,--dynamic-linker=/opt/lib/ld-linux-x86-64.so.2' --with-default-libstdcxx-abi=gcc4-compatible
Thread model: posix
gcc version 7.4.0 (OpenWrt GCC 7.4.0)
COMPILER_PATH=/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/:/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/
LIBRARY_PATH=/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/:/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/:/lib/../lib64/:/usr/lib/../lib64/:/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/../../../:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS='-v' '-mtune=generic' '-march=x86-64'
 /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/collect2 -plugin /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/liblto_plugin.so -plugin-opt=/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/lto-wrapper -plugin-opt=-fresolution=/tmp/ccm1Y6FA.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s --eh-frame-hdr -m elf_x86_64 -dynamic-linker /lib64/ld-linux-x86-64.so.2 /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crt1.o /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crti.o /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crtbegin.o -L/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0 -L/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc -L/lib/../lib64 -L/usr/lib/../lib64 -L/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/../../.. -rpath=/opt/lib --dynamic-linker=/opt/lib/ld-linux-x86-64.so.2 -lgcc_s -lc -lgcc_s /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crtend.o /volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crtn.o
/volume1/.@plugins/AppCentral/entware/opt/bin/../lib/gcc/x86_64-openwrt-linux-gnu/7.4.0/crt1.o: In function `_start':
(.text+0x20): undefined reference to `main'
collect2: error: ld returned 1 exit status
Iwao@AS5202T:/volume1/home/Iwao $
Iwao@AS5202T:/volume1/home/Iwao $ ll
total 12
drwxr-xr-x    2 Iwao     users       4.0K Mar 16 18:27 ./
drwxr-xr-x    4 root     root        4.0K Mar 16 15:19 ../
-rw-------    1 Iwao     users        100 Mar 16 18:43 .ash_history
Iwao@AS5202T:/volume1/home/Iwao $ mkdir test
Iwao@AS5202T:/volume1/home/Iwao $ cd test
Iwao@AS5202T:/volume1/home/Iwao/test $ cat > test.cpp
int     main    ()
{
        return  2 ;
        }
Iwao@AS5202T:/volume1/home/Iwao/test $ cat test.cpp
int     main    ()
{
        return  2 ;
        }
Iwao@AS5202T:/volume1/home/Iwao/test $ ls
test.cpp
Iwao@AS5202T:/volume1/home/Iwao/test $ g++ test.cpp
Iwao@AS5202T:/volume1/home/Iwao/test $ ./a.out
Iwao@AS5202T:/volume1/home/Iwao/test $ echo $?
2
Iwao@AS5202T:/volume1/home/Iwao/test $ echo $?
0
Iwao@AS5202T:/volume1/home/Iwao/test $


https://jml.mish.work/various/nas/asustor.html

この投稿は役に立ちましたか? 役に立った 役に立たなかった 0 人中 0 人がこの 投稿 は役に立ったと言っています。